ArcGIS Enterprise Dağıtımının TLS 1.2 ArcGIS Online Güncellemesinden etkilenip etkilenmediğini nasıl anlarım?

ArcGIS Online güvenliğini geliştirmenin bir parçası olarak, Esri; ArcGIS Online hizmetleri için TLS 1.2 bağlantısını zorunlu kılmak için bir güncelleme gerçekleştirmiştir. Kuruluşunuzun bünyesinde hizmet vermekte olan ArcGIS Enterprise dağıtımınızın bu güncelllemeden etkilenip etkilenmediğini öğrenmek için aşağıdaki şemayı inceleyebilirsiniz. Ayrıca; “ArcGIS Enterprise Bileşenleri Yeni TLS Düzenlemesinden Nasıl Etkilenecekler?” isimli yazımızı da inceleyerek, bu yazıda bahsedilen işlemlerden size uygun olan adımları uygulayabilirsiniz.

ArcGIS Enterprise Bileşenleri Yeni TLS Düzenlemesinden Nasıl Etkilenecekler?

PDF olarak indirmek için tıklayınız.

İlgili Bağlantılar:

© Esri Türkiye 2019

Windows, .NET4 Framework kullanan uygulamalar için TLS 1.2 kullanacak şekilde nasıl yapılandırılır?

Özet

ArcGIS Online güvenliğini iyileştirmenin bir parçası olarak Esri, ArcGIS Online servisleri için TLS 1.2 bağlantısı gerektirir. Bu servislere sürekli erişim sağlamak için aksiyon almak gereklidir.

Aşağıdaki adımlar Windows işletim sisteminin TLS 1.2 kullanacak şekilde nasıl ayarlanacağını açıklar. Bu, TLS 1.2 kullanmak için Microsoft .NET4 Framework’e bağlı olan sistemdeki tüm uygulamalara izin verir. Bu, işletim sistemi seviyesinde bir değişikliktir ve sadece bir kere yapılmalıdır. Eğer önceden başka bir Esri ürünü için bu talimatları uyguladıysanız ve Windows’ta TLS 1.2’yi etkinleştiren Windows Registry anahtarlarını oluşturduysanız bu adımları tekrarlamanıza gerek yoktur.

Bu, TLS 1.2’yi açıkça destekleyecek bir ürün yükseltmesi olmadığında veya uygulanamadığında, ArcGIS uygulamalarını TLS 1.2 kullanacak şekilde yapılandırmak için isteğe bağlı bir yöntemdir. Önerilen çözüm, TLS 1.2’yi destekleyen ürün versiyonuna yükseltmektir.

Daha fazla bilgi için Esri Support TLS sayfasını ziyaret edebilirsiniz. Hangi yaklaşımı kullanacağınıza karar verirken durumunuzu dikkatlice göz önünde bulundurun: Esri .NET ortamını TLS 1.2’yi etkinleştirecek şekilde ayarlamanın ArcGIS ile problemlere yol açmayacağının garantisini vermiştir fakat varsayılan TLS davranışının değiştirilmesi diğer .NET uygulamalarını etkileyebilir.

Eğer sistem 3.5.1 .NET versiyonunu kullanıyorsa ve .NET4 yüklemek olası değilse TLS 1.2’yi etkinleştirme adımları için bu makaleye bakınız: How To: Configure Windows to use TLS 1.2 for applications that use the .NET 3.5.1 Framework.

Prosedür

Dikkat: Aşağıdaki talimatlar işletim sisteminizin ana parçalarında değişiklikleri içerir. Devam etmeden önce, işletim sisteminizin ve dosyalarınızın (kayıt dahil) yedeğini almanız önerilir. Eğer gerekliyse kalifiye bir bilgisayar sistemleri uzmanına danışın.

  1. Microsoft .NET4’ün kurulduğundan emin olun.

Bkz: How to: Determine which .NET Framework versions are installed

  1. Eğer gerekliyse Microsoft Download Center’dan .NET4 indirin: Microsoft .NET Framework 4.7 (Web Installer).
  2. Bu .zip dosyasını indirin ve çıkarın: TLS_NET4.zip
  3. TLS_NET4.reg dosyasını çıkarın ve uygun Windows Registry anahtarlarını oluşturmak için dosyayı açın.
  4. TLS 1.2 bağlantınızı ArcGIS Online’a bağlanarak test edin.

İlgili Bağlantılar:

ArcGIS Desktop için TLS 1.2 yaması nasıl kurulur?

Özet:

Not: ArcGIS Desktop’ı TLS 1.2 kullanacak şekilde yapılandırmak için önerilen çözüm budur. Diğer seçeneklerin açıklamaları için bkz. SSS: ArcGIS Desktop’ta TLS 1.2’yi nasıl etkinleştirebilirim?

ArcGIS Online güvenliğini iyileştirmenin bir parçası olarak Esri, ArcGIS Online servisleri için TLS 1.2 bağlantısı gerektirir. Bu servislere erişim sağlamak için aksiyon almak gereklidir. Aşağıda yer alan metotlar ArcGIS Desktop’ın TLS 1.2 kullanacak şekilde nasıl yapılandırılacağını tanımlar fakat sistemdeki diğer uygulamaları etkilemez.

Not: ArcGIS Desktop’un yayınlanan her versiyonunun destek durumunu Esri Support sitesinden Product Life Cycle sayfalarında bulabilirsiniz.

Prosedür:

ArcGIS Desktop versiyonuna bağlı olarak uygulamayı TLS 1.2 kullanacak şekilde yapılandırmak için aşağıda yer alan prosedürlerden birini kullanın.

Not: ArcGIS Desktop’u TLS 1.2 kullanması için yapılandırdıktan ve test ettikten sonra diğer Esri ürünlerinde TLS 1.2’nin nasıl kullanıldığına dair talimatlar için Esri Support TLS Page’e geri dönün.

ArcGIS 10.4.0-10.6.1:

  1. Kullanmakta olduğunuz versiyon için ArcGIS Desktop TLS patch’i indirin ve kurun.
  2. ArcGIS Online’a TLS 1.2 ile bağlanmayı deneyin.

ArcGIS 10.2.1-10.3.1:

Bu aralıkta yer alan sürümler TLS 1.2’nin desteklemediği Microsoft .NET’in eski versiyonunu kullanır.

  1. Kullanmakta olduğunuz Microsoft .NET versiyonunuzu teyit edin. Bu bilgi aşağıda yer alan Microsoft Help dokümanından edinilebilir.

How to: Determine which .NET Framework versions are installed.

  1. Eğer gerekliyse .NET4 Framework kurun. Bu Microsoft Download Center’dan edinilebilir.

Not: İlerleyen adımlara .NET4’e yükseltildikten sonra devam edilmesi önerilir. Fakat .NET4’e yükseltmek uygulanabilir değilse, işletim sisteminizi TLS 1.2 kullanacak şekilde yapılandırmak gereklidir. Bkz. Windows, ArcGIS Desktop için TLS 1.2 kullanacak şekilde nasıl ayarlanır?

  1. Kullanmakta olduğunuz versiyon için ArcGIS Desktop TLS patch’i indirin ve kurun.
  2. ArcGIS Online’a TLS 1.2 ile bağlanmayı deneyin.

İlgili Bağlantılar:

SSS: ArcGIS Pro’da TLS 1.2’yi nasıl etkinleştirebilirim?

Soru:

ArcGIS Pro’da TLS 1.2’yi nasıl etkinleştirebilirim?

Cevap:

Esri, en son çıkan güvenlik protokollerini kullanarak ArcGIS Platformu için güçlü bir güvenlik sistemi inşa etmek ve sağlamak için kendini adamıştır. Biz, veri entegrasyonu ve ağ güvenliği için TLS’i de içeren en yüksek endüstri standartlarını uygulamak için uğraşmaktayız.

Esri, bu standartlara ulaşmak için ArcGIS Platformunun bir ucundan diğer ucuna TLS 1.2’yi destekleyen yazılım güncellemeleri yapmaktadır. ArcGIS Online güvenliğini iyileştirmenin bir parçası olarak Esri, ArcGIS Online servisleri için TLS 1.2 bağlantısı gerektirir. Bu servislere sürekli erişim sağlamak için aksiyon almak gereklidir.

Not: ArcGIS Desktop’un yayınlanan her versiyonunun destek durumunu Esri Support sitesinden Product Life Cycle sayfalarında bulabilirsiniz.

Bu konuyu çözümlendirme adımları kullanılmakta olan ArcGIS Pro versiyonuna bağlıdır:

ArcGIS Pro 1.3 – 2.3 versiyonları:

TLS 1.2 kullanmak için herhangi bir işlem yapılmasına gerek yoktur. ArcGIS 1.3 – 1.4.1 versiyonları emekli olduğu için Esri’nin en son versiyona yükseltmeyi önerdiğini unutmayınız.

ArcGIS Pro 1.0 – 1.2 versiyonları:

TLS 1.0 destekleyen bu versiyonlar emekli olmuştur ve güncellenmeyecektir. Eğer emekli olmuş bir ArcGIS Pro versiyonu kullanmaya devam edecekseniz 2 seçeneğiniz bulunmaktadır:

  • ArcGIS Pro’nun desteklenen bir versiyonuna yükseltin (Önerilen).
  • İşletim sistemini TLS 1.2 kullanacak şekilde ayarlamak. Bu Microsoft .NET Framework’e bağlı tüm uygulamaların TLS 1.2 kullanmalarını sağlar.

Bkz. Windows, .NET4 Framework kullanan uygulamalar için TLS 1.2 kullanacak şekilde nasıl yapılandırılır?

Not: Hangi yaklaşımı kullanacağınıza karar vereceğinizde durumunuzu göz önünde bulundurun. .NET  ortamının ayarlanmasının TLS 1.2’yi etkinleştirmek ArcGIS ile herhangi bir probleme yol açmayacaktır fakat varsayılan TLS davranışının değiştirilmesi diğer uygulamaları etkileyebilir. Eğer gerekliyse nitelikli bir bilgisayar sistem profesyoneline danışın.

İlgili Bağlantılar:

Windows, ArcGIS Desktop için TLS 1.2 kullanacak şekilde nasıl ayarlanır?

Özet:

Not: Bu ArcGIS Desktop’u TLS 1.2 kullanacak şekilde ayarlamak için opsiyonel bir çözümdür. Önerilen seçenek dahil diğer seçeneklerin açıklamaları için bkz. SSS: ArcGIS Desktop’ta TLS 1.2’yi nasıl etkinleştirebilirim?

ArcGIS Online güvenliğini iyileştirmenin bir parçası olarak Esri, ArcGIS Online servisleri için TLS 1.2 bağlantısı gerektirir. Bu servislere erişim sağlamak için aksiyon almak gereklidir.

Aşağıdaki metotlar Windows işletim sisteminin TLS 1.2 kullanacak şekilde nasıl ayarlanacağını açıklar. Bu, TLS 1.2 kullanmak için Microsoft .NET4 Framework’e bağlı olan sistemdeki tüm uygulamalara izin verir.

Not: Esri .NET ortamını TLS 1.2’yi etkinleştirecek şekilde ayarlamanın ArcGIS ile problemlere yol açmayacağının garantisini vermiştir fakat varsayılan TLS davranışının değiştirilmesi diğer .NET uygulamalarını etkileyebilir. Eğer gerekliyse kalifiye bir bilgisayar sistemleri uzmanına danışın.

Prosedür:

Not: ArcGIS Desktop’u TLS 1.2 kullanması için yapılandırdıktan ve test ettikten sonra diğer Esri ürünlerinde TLS 1.2’nin nasıl kullanıldığına dair talimatlar için Esri Support TLS Page’e geri dönün.

Windows’u TLS 1.2 kullanacak şekilde ayarlamak sistemde kurulu olan .NET Framework versiyonuna bağlıdır. Esri, eğer mümkünse, .NET4 kullanılmasını önerir.

A. Kullanılmakta olan .NET versiyonunu doğrulayın. Bu bilgi aşağıdaki Microsoft Yardım dokümanında bulunabilir:

How to: Determine which .NET Framework versions are installed.

B. Eğer .NET4 zaten kuruluysa Windows işletim sistemini TLS 1.2 kullanacak şekilde ayarlamak için aşağıdaki adımları izleyin:

  1. Zip dosyasını indirin: TLS_NET4.zip
  2. Ziplenmiş dosyanın içeriğini çıkarın ve uygun Windows Registry anahtarlarını oluşturmak için TLS_NET4.reg dosyasına çift tıklayın.
  3. ArcGIS Online’a TLS 1.2 bağlantınızı test edin.

C. Eğer .NET4 sisteminizde kurulu değilse Esri kurulmasını önerir:

  1. Microsoft Download Center’dan .NET4 Framework’ü indirin ve kurun: Microsoft .NET Framework 4.7 (Web Installer).
  2. Yukarıdaki B maddesinde yer alan adımları takip edin.

D. Eğer sistem 3.5.1 .NET versiyonunu kullanıyorsa ve .NET4’e yükseltmek olası değilse TLS 1.2’yi etkinleştirmek için bu adımları izleyin:

  1. TLS 1.2’yi etkinleştirmek için Microsoft güncellemelerini yükleyin. Microsoft, tüm işletim sistemi güncellemelerinin yüklenmesini önerir. .NET Framework ile Transport Layer Security (TLS) en iyi uygulamaları: Requirements to support TLS 1.2 with .NET Framework 3.5

Aşağıda TLS 1.2 güncellemeleri mevcuttur:

  1. Zip dosyasını indirin: TLS_NET35.zip.
  2. Dosyayı çıkarın ve uygun Windows Registry anahtarlarını oluşturmak için TLS_NET35.reg dosyasına çift tıklayın.
  3. ArcGIS Online’a TLS 1.2 bağlantınızı test edin.

Not: ArcGIS Desktop’un yayınlanan her versiyonunun destek durumunu Esri Support sitesinden Product Life Cycle sayfalarında bulabilirsiniz.

İlgili Bağlantılar: