Özet

Not:

Bu ArcGIS Desktop’I TLS 1.2 kullanacak şekilde yapılandırmak için isteğe bağlı bir çözümdür. Önerilenler de dahil olmak üzere diğer seçeneklerin açıklaması için, bkz. Nasıl ArcGIS Destop’ta TLS 1.2 nasıl etkinleştirebilirim?

ArcGIS Online güvenliğini geliştirmenin bir parçası olarak Esri, ArcGIS Online servisleri için TLS 1.2 bağlantısı gerektirmektedir. Bu hizmetlere erişimin sağlanması için yapılması gerekenler bulunmaktadır.

Aşağıdaki belirtilen yöntemler Windows işletim sisteminin TLS 1.2 kullanımı için nasıl yapılandırılacağını açıklar. Bu, Microsoft .NET Framework’e bağlı olan sistemdeki tüm uygulamaların TLS 1.2 kullanımını sağlar.

Not:

Esri, TLS 1.2 aktifleştirmek için .Net ortamı ayarlarının değiştirilmesinin ArcGIS ile problem oluşturmayacağını onaylamış olsa bile, değişikliğin diğer .NET uygulamalarının varsayılan TLS davranışlarının değişmesine sebep olacaktır. Gerekli olması durumunda kalifiye bilgisayar sistemleri uzmanına danışın.

Prosedür

Not:

ArcGIS Desktop’un TLS 1.2 kullanımı için ayarlanması ve testinden sonra, TLS 1.2’nin diğer Esri ürünleriyle nasıl kullanılacağı hakkında bilgi için Esri Destek TLS Sayfasına bakınız.

Windows’un TLS 1.2 kullanımı aktifleştirmesini sağlayan adımlar, sistemde yüklü .Net Framework versiyonuna bağlıdır. Esri, mümkünse .NET 4 versiyonunun kullanımını önerir.

    1. Kullanılan .NET versiyonunu belirleyin. Bu bilgi aşağıdaki Microsoft Yardım dokümanında belirtilmiştir:
      How to: Determine which .NET Framework versions are installed.
    2. Eğer .NET 4 versiyonu yüklüyse, aşağıdaki adımları uygulayarak Windows işletim sisteminin TLS kullanımını ayarla:
      1. TLS_NET4.zip zip dosyasını indirin.
      2. Sıkıştırılmış dosyayı açın ve ‘TLS_NET4.reg’ dosyasını çift tıklayarak, Windows Kayıt Defterinde uygun kayıt anahtarlarını oluşturun.
      3. ArcGIS Online ile TLS 1.2 bağlantısını test edin.
    3. Eğer .NET 4 versiyonu sistemde yüklü değilse, Esri yüklemenizi tavsiye eder:
      1. Microsoft Download Center’dan indir ve yükle dosyayı:
      Microsoft .NET Framework 4.7 (Web Installer).
      2. Üstteki bölüm B’deki adımları uygulayın.
    4. Eğer sistem .NET 3.5.1 versiyonunu kullanıyorsa ve .NET 4 versiyonuna güncellemek uygun değilse TLS 1.2 aktifleştirmek için aşağıdaki adımları uygulayın:
      1. Microsoft güncellemelerini TLS 1.2 aktifleştirmek için yükleyin. Microsoft tüm işletim sistemi güncellemelerinin yüklenmesini önerir. Bkz: .NET Framework ile Aktarım Katmanı Güvenliği (TLS) için en iyi yöntemler: Requirements to support TLS 1.2 with .NET Framework 3.5
      Aşağıdaki TLS 1.2 güncellemeleri mevcuttur:
      • Windows 7 SP1 veya Windows Server 2008 R2 SP1 – Microsoft update 31545:
      Support for TLS System Default Versions included in the .NET Framework 3.5.1 on Windows 7 SP1 and Server 2008 R2 SP1
      • Windows 8.0 veya Windows Server 2012 – Microsoft update 3154519:
      Support for TLS System Default Versions included in the .NET Framework 3.5 on Windows Server 2012
      • Windows 8.1 veya Windows Server 2012 R2:
      Support for TLS System Default Versions included in the .NET Framework 3.5 on Windows 8.1 and Windows Server 2012 R2
      • Windows 10 veya Windows Server 2016:
      Cumulative Update for Windows 10 Version 1511 and Windows Server 2016 Technical Preview 4: May 10, 2016
      • Windows Server 2008:
      Support for TLS System Default Versions included in the .NET Framework 2.0 SP2 on Windows Vista SP2 and Server 2008 SP2
      • Windows Vista: Desteklenmemektedir
      2. TLS_NET35.zip zip dosyasını indirin.
      3. Sıkıştırılmış dosyayı açın ve ‘TLS_NET35.reg’ dosyasını çift tıklayarak, Windows Kayıt Defterinde uygun kayıt anahtarlarını oluşturun.
      4. ArcGIS Online ile TLS 1.2 bağlantısını test edin.
Not:

ArcGIS Desktop versiyonlarının her birinin destek durumu için Esri Destek sitesindeki Product Life Cycle sayfalasına bakın.

İlgili Bağlantılar:

Share This