Esri, ArcGIS Platformu ve son güvenlik protokollerini kullanarak müşterilerine yardımda güçlü güvenlik oluşturmak ve desteklemek için kararlıdır. Veri bütünlüğü ve ağ güvenliği için TLS dahil olmak üzere en yüksek endüstri standartlarını uygulamak için çalışmaktadır.

Bu standartları karşılamak için Esri ArcGIS Platformunda TLS 1.2’yi desteklemek üzere yazılım güncellemeleri yapmaktadır. ArcGIS Online güvenliği geliştirilmesinin bir parçası olarak Esri, ArcGIS Online hizmetleri için TLS 1.2 bağlantısını gerektirmektedir. Bu servislere erişimin devamlılığı için yapılması gereken eylemler mevcuttur.

Not:

ArcGIS Runtime SDK for Android versiyonlarının her birinin destek durumu için Esri Destek sitesindeki Product Life Cycle sayfasına bakın.

ArcGIS Runtime SDK for Android 10.2.9 ve 100.x versiyonları, Android 5.0 ve üstü (API 21 ve üstü) versiyonlarında çalışan cihazlarda TLS 1.2 desteklenmektedir.

Ancak Android 4.4 (API 19) ve daha öncesi, 100.x ve 10.2.9 SDK’lı cihazlarda ağ istekleri aşağıdaki hata ile başarısız olur:

javax.net.ssl.SSLException: SSL handshake aborteds

Android 4.4 (API 19) çalıştıran cihazlarda TLS 1.2 desteklemek için, kullanıcılar, Android geliştirici dokümanındaki ‘Update your security provider to protect against SSL exploitsbölümde belirtildiği gibi cihazın güvenlik sağlayıcısını güncellemek için kendi uygulamalarına kod eklemek zorundadır.

Not:

Önerilen çözüm sadece Google Play Services uygulaması yüklü cihazda çalışır, aksi halde güvenlik sağlayıcısını güncelleme girişimi ‘GooglePlayServicesNotAvailableException’ ile sonuçlanır. Uygulamanız Google Play Services olmayan cihazları hedeflemesi muhtemelse, uygulamanızı yalnızca Android 5.0 ve daha üstü (API 21 ve üstü) sürümü olan cihazlar için hedeflemeniz önerilebilir.

TLS 1.2 desteklenenler:

Android API Seviyesi 10.2.9 100.x
19 ve altı (X)* (X)*
21 ve üstü X X

*Aygıtın güvenlik sağlayıcısını güncellemek için yukarıda açıklandığı gibi uygulama düzeyinde kod yazımı gerekir.

İlgili Bağlantılar:

Share This