ArcGIS Online güvenliğinin arttırılması için Esri, 16 Nisan 2019 tarihinden itibaren TLS 1.2 protokolünün kullanımını zorunlu kılacaktır. ArcGIS Online servislerini kullanan Esri ürünlerinin bu durumdan etkilenmemesi için yapılandırılması gerekmektedir. Bu yazımızda TLS 1.2 güncellemesinden etkilenecek Esri ürünlerinden ve kullanıcıların bu güncellemeden sonra platformu sorunsuz kullanmaya devam edebilmesi için yapması gerekenlerden bahsedeceğiz.

ArcGIS Platformu, ArcGIS Desktop çözümlerinden ArcGIS Enterprise’a ve mobil çözümlere kadar geniş bir ürün yelpazesine sahiptir. Aşağıda hangi ürünlerin bu güncellemeden etkilenip etkilenmediğine dair bilgilerin yer aldığı tablolar bulunmaktadır. Ayrıca, bu yazımızın sonunda TLS güncellemesiyle ilgili sık sorular soruların cevaplarını ve TLS ile ilgili diğer faydalı kaynakların yer aldığı bağlantıları da tek bir sayfa içerisinde bulabilirsiniz.

Etkilenen Ürünler

Desktop 

ArcGIS Pro
2.0 – 2.3 TLS 1.2’yi desteklemektedir, herhangi bir işlem yapılmasına gerek yoktur.
1.2 – 1.4.1 Bu versiyonlar Esri tarafından artık desteklenmeyen versiyonlardır. Önerilen yöntem kullandığınız yazılımın sürümünü yükseltmenizdir. Eğer böyle bir şansınız yoksa TLS 1.2’yi işletim sisteminiz üzerinden aktifleştirme yolunu izleyebilirsiniz.
ArcGIS Pro 1.2 – 1.4.1 sürümlerini kullanıyorsanız yapmanız gereken işlemler için lütfen SSS: ArcGIS Pro’da TLS 1.2’yi Nasıl Etkinleştirebilirim?  bloguna gidiniz.
ArcMap | ArcCatalog | ArcScene | ArcGlobe
10.7 TLS 1.2’yi desteklemektedir.
10.6.1 ve öncesi ArcGIS Desktop ürününüzü nasıl yapılandıracağınızı öğrenmek için ArcGIS Desktop İcin TLS 1.2 Yaması Nasıl Kurulur? blog yazımızı inceyeleyebilirsiniz.
10.3.1 ve öncesi Kullandığınız işletim sisteminin TLS 1.2’yi destekleyebilecek bir .NET sürümüne sahip olması gerekmektedir. .NET 4 sürümü yüklenemezse, Microsoft’un TLS için yayınladığı .NET 3 yaması yüklenmelidir. Önerilen bu yamayı  yükleyemiyorsanız Windows üzerinde TLS 1.2 desteklenebilmesi için yapılacak işlem adımları için Windows ArcGIS Desktop İcin TLS 1.2 Kullanacak Şekilde Nasıl Ayarlanır? başlıklı  blog yazısını okuyabilirsiniz.
ArcGIS Desktop için TLS 1.2’nin nasıl aktifleştirileceğini öğrenmek için SSS: ArcGIS Desktop’ta TLS 1.2’yi Nasıl Etkinleştirebilirim? blog yazısını inceleyebilirsiniz.

Enterprise 

ArcGIS Enterprise 
10.6.1 – 10.5 TLS 1.2’yi desteklemektedir.
ArcGIS Enterprise sisteminizin TLS 1.2 güncellemesinden nasıl etkileneceğini öğrenmek için blog yazımızdaki şemayı inceleyebilirsiniz.
Portal for ArcGIS
10.6.1 – 10.4.1 TLS 1.2’yi desteklemektedir.
10.4 ve öncesi JAVA7 kullanarak oluşturulan yazılımlar TLS 1.2’yi desteklememektedir. Portal for ArcGIS yazılımınızı 10.4.1 sürümüne veya 10.6.1 sürümüne yükseltmeniz gerekmektedir.
ArcGIS Server
Windows Server 2012 R2 veya üstü bir işletim sistemi üzerinde kurulu olan ArcGIS Server için Varsayılan yapılandırma ayarları ile TLS 1.2’yi desteklemektedir.
Windows Server 2008 R2 veya 2012 üzerinde kurulu olan ArcGIS Server için Bu işletim sistemlerinde  TLS 1.2’nin desteklenmesi için yapılandırma gerçekleşmesi gerekir.
Windows 2008 Server üzerinde kurulu olan ArcGIS Server için ArcGIS Server’ın bazı fonksiyonları çalışmayacaktır. İşletim sisteminizi Windows Server’ın bir üst sürümüne taşıyınız.
Linux üzerine kurulu olan ArcGIS Server için ArcGIS Server’ı destekleyen tüm sürümlerinde TLS 1.2’yi desteklemektedir.
ArcGIS GeoEvent Server
10.7 – 10.4 TLS 1.2′ yi desteklemektedir.
10.3.1 ve öncesi sürümler için TLS 1.2’yi desteklemeyen ArcGIS Enterprise sistemleri yapılacak olan değişiklikten etkilenecektir. 10.3.1 ve öncesi sürümlerdeki ArcGIS GeoEvent Server’ınızın içerisinde veri deposu olarak ArcGIS Online bağlantısı bulunan servisler varsa sunucunuzu 10.4 ve üstü sürümlere yükseltmeniz gerekmektedir.

ArcGIS Desktop/Engine 

.NET Geliştiricileri
Bu çözümün kullanıcıları için yapılacak işlem adımlarını Zorunlu TLS 1.2 Bağlantılarında ArcOcbject SDK’nın Microsoft .NET Framework ve ArcGIS Engine .NET İstemci Uygulamalarında Etkileri Nelerdir?  bağlantısından inceleyebilirsiniz.
Linux ile kullanılan ArcGIS Engine 
TLS 1.2’yi desteklemez.
C++ Geliştiriciler İçin
ArcObjects C++ 10.7 TLS 1.2’yi desteklemektedir.
ArcObjects C++ 10.6.1 ve öncesi TLS 1.2’yi desteklememektedir. 10.7 sürümüne yükseltmeniz gerekmektedir.
Not: Eğer üçüncü parti bir ağ kütüphanesi (OpenSSL vb.) kullanarak ArcGIS Online’dan gelen veriye erişiyorsanız, bu kütüphanelerin TLS 1.2’yi desteklediğinden emin olunuz.
Java Geliştiricileri
ArcGIS 10.4 ve sonrası sürümler JAVA8 ile derlenen “Java Interop” ögeleri TLS 1.2’yi desteklemektedir.
ArcGIS 10.3.1 ve öncesi sürümler JAVA7 ile derlenen “Java Interop” ögeleri için TLS 1.2 servislerine erişirken JAVA SSL’i başlatmaları gerekmektedir.
Python Geliştiricileri
Bağımsız Python araçlarının geliştiricileri, TLS 1.2’yi kendileri başlatmalıdır.

ArcGIS Runtime SDK

ArcGIS Runtime SDK – Android
100.x ve 10.2.9 Android 5.0 ve üstü sürümler: Android 5.0 (API 21) ve üstü sürümlere sahip cihazlarda  TLS 1.2 desteklenmektedir.

Android 4.4 ve öncesi sürümler: Android 4.4 (API 19) ve öncesi sürümlere sahip cihazlarda TLS 1.2′ nin ayarlanması gerekmektedir.

Android için ArcGIS Runtime SDK kullanılacak çalışmalarda TLS 1.2’nin nasıl aktifleştirileceğini öğrenmek için ArcGIS Runtime SDK for Anroid İçin TLS 1.2 Nasıl Aktifleştirilir? başlıklı blog yazımızı inceleyiniz.
ArcGIS Runtime SDK – iOS ve macOS
100.4 TLS 1.2’yi desteklemektedir.
10.2.x TLS 1.2’yi desteklemektedir.
ArcGIS Runtime SDK – Java
100.4 ve 10.2.x Java 8: Java 8 181 güncellemesi veya daha üstü kullanılıyorsa TLS 1.2’yi desteklemektedir.

Java 7: TLS 1.2’yi desteklememektedir.

ArcGIS Runtime SDK – Java için kullanılacak çalışmalarda TLS 1.2′ nin nasıl aktifleştirileceğini öğrenmek için ArcGIS Runtime SDK for Java İçin TLS 1.2 Nasıl Aktifleştirilir? başlıklı blog yazımızı inceleyiniz.
ArcGIS Runtime SDK – .NET
100.0 ve üstü sürümler TLS 1.2’yi desteklemektedir.
10.2.x Windows Desktop TLS 1.2′ nin aktifleşebilmesi için .NET 4 yüklenmelidir. Eğer .NET 4 yüklenemiyorsa Microsoft .NET 3 yüklenmelidir. Yapılacak işlemler için Nasıl Yapılır: ArcGIS Desktop’ın TLS 1.2 Kullanımı İçin Yapılandırılması blog yazısını inceleyiniz.
 

10.2.x Windows işletim sistemine sahip telefonlar

TLS 1.2’yi desteklememektedir..
10.2.x – Windows Store TLS 1.2’yi desteklememektedir.
ArcGIS Runtime SDK – .NET için TLS 1.2′ nin nasıl aktifleştirileceğini öğrenmek için ArcGIS Runtime SDK for .NET İçin TLS 1.2 Nasıl Aktifleştirilir?  başlıklı yazımızı inceleyiniz.
ArcGIS Runtime SDK – Qt
100.x ve 10.2.6 TLS 1.2’yi desteklemektedir fakat aktifleştirilmesi için ayarlama yapılması gerekmektedir.
ArcGIS Runtime SDK – Qt için TLS 1.2′ nin nasıl aktifleştirileceğini öğrenmek için ArcGIS Runtime SDK for Qt İçin TLS 1.2 Nasıl Aktifleştirilir?  başlıklı yazımızı inceleyiniz.
ArcGIS Runtime SDK – WPF
TLS 1.2’yi desteklemez. Bu ürünün yayınlanması durdurulmuştur ve desteklenmemektedir.

ArcGIS Runtime for WPF Ürün Yaşam Döngüsü bağlantısından detaylı bilgi alabilirsiniz.

ArcGIS Uygulamaları

ArcGIS Business Analyst Desktop
10.6.1 – 10.5 ArcGIS Business Analyst Desktop TLS yamasını https://support.esri.com/en/download/7676 bağlantısı üzerinden indirerek kurmanız gerekmektedir.
ArcGIS Earth
1.5 – 1.9 TLS 1.2’yi desteklemektedir.
1.0 – 1.4 Bu versiyonlar artık desteklenmemektedir, lütfen ArcGIS Earth’ün güncel sürümünü yükleyiniz. Eğer yükseltme işlemi gerçekleştiremiyorsanız işletim sisteminiz üzerinden TLS 1.2’yi aktifleştirebilirsiniz.
ArcGIS Earth için TLS 1.2′ nin nasıl aktifleştirileceğini öğrenmek için SSS: ArcGIS Earth’de TLS 1.2’yi nasıl aktif ederim? makalesini inceleyiniz.
Drone2Map
1.3.2 TLS 1.2’yi destekler. Esri, uygulama kullanıcılarının uygulamayı bu sürüme yükseltmesini önermektedir.
1.3.2 ve öncesi Bu sürümlerin kullanıcıları Windows işletim sistemi üzerinde değişiklik yapmaları gerekmektedir. .NET4 framework için TLS 1.2’nin nasıl aktifleştirileceğini öğrenmek için Windows .NET4 Framework Kullanan Uygulamalar İçin TLS 1.2 Kullanacak Şekilde Nasıl Yapılandırılır?  bağlantısını inceleyiniz.
Drone2Map uygulamanız için TLS 1.2’yi aktifleştirme ile ilgili dokümanı SSS: Drone2Map for ArcGIS İçin TLS 1.2 Yapılandırmasını Nasıl Yaparım? bağlantısından bulabilirsiniz.
Operations Dashboard for ArcGIS – Windows
TLS 1.2’yi aktif hale getirmek için Windows ArcGIS Desktop İcin TLS 1.2 Kullanacak Şekilde Nasıl Ayarlanır? bağlantısındaki işlem adımlarını uygulayınız.
WebApp Builder for ArcGIS – Developer Sürümü
Web AppBuilder for ArcGIS ile derlediğiniz uygulamaları yeniden yapılandırmanıza gerek yoktur. Bu uygulamalar TLS 1.2 üzerinden isteklerini yollamak için kullanılan tarayıcıya güvenecektir. Bu noktada dikkat edilmesi gereken güncel işletim sistemleri bu işlemi tarayıcılarında yapabilecektir fakat Windows XP gibi versiyon işletim sistemleri bunu gerçekleştiremeyebilir. ArcGIS Online dışında bir ortamda, ArcGIS Online içerisinde  barındırılan katmanlarla çalışıyorsanız, sunucunuzun ArcGIS Online’a bağlanabilmesi ve üzerinden eklenecek servislere güvenebilmesi için  TLS 1.2’yi desteklemesi gerekecektir.
Herkese açık olan servisler için SSL Labs – SSL Server Test tool aracı ile TLS destekleme durumundan emin olmak için test yapılabilir.

Dışarıya açık olmayan servisler için ise IISCryptoTool aracı ile desteklenen TLS versiyonları doğrulanabilir.

Plug-in Uygulamalar 

ArcGIS for AutoCAD
370 ve öncesi Bu sürümdeki ArcGIS for AutoCAD uygulamasında nasıl bir değişiklik yapacağınıza dair lütfen Windows .NET4 Framework Kullanan Uygulamalr İçin TLS 1.2 Kullanacak Şekilde Nasıl Yapılandırılır?  yazısındaki işlem adımlarını inceleyiniz.
ArcGIS for AutoCAD için TLS 1.2’yi nasıl aktifleştireceğinize dair SSS: ArcGIS for AutoCAD’te TLS 1.2’yi Nasıl Aktif Edebilirim? bağlantısındaki dokümanı inceleyiniz.
Esri Maps for Dynamic CRM
TLS 1.2’yi desteklememektedir. (Ürün Desteği sonlandırıldı.)
Esri Maps for Salesforce
TLS 1.2′ yi desteklememektedir. (Ürün Desteği sonlandırıldı.)

Mobil Uygulamalar

ArcPad
Windows Desktop Herhangi bir işlem yapmanıza gerek yoktur.
Windows Mobile Detay servislerin ve ArcPad paketlerinin yükleme/indirme işlemleri Windows Mobile içerisinde TLS 1.2 ile çalışmayacaktır.
Collector for ArcGIS – Android
TLS 1.2’yi desteklemesi için Android API 21 ve üstü bir sistemde çalışmalıdır.
Explorer for ArcGIS – Android
TLS 1.2’yi desteklemesi için Android API 21 ve üstü bir sistemde çalışmalıdır.
Navigator for ArcGIS – Android 
TLS 1.2’yi desteklemesi için Anroid API 21 ve üstü bir sistemde çalışmalıdır.
Tracker for ArcGIS – Android
TLS 1.2’yi desteklemesi için Android API 21 ve üstü bir sistemde çalışmalıdır.
Workforce for ArcGIS – Android
TLS 1.2’yi desteklemesi için Anroid API 21 ve üstü bir sistemde çalışmalıdır.

ArcGIS Platformu Uygulamaları, Ek Bileşenleri ve Çözümleri

Aşağıda bahsedilen uygulamalar, ek bileşenler ve çözümler eğer ArcGIS Desktop ürünü  TLS 1.2’ye uygun şekilde yapılandırılmışsa herhangi bir şekilde etkilenmeyecektir.

ArcGIS Data Reviewer ArcGIS for Aviation: Airports
ArcGIS for Maritime: Charting ArcGIS for Maritime: Server
ArcGIS Pipeline Referencing Esri Defense Mapping
Esri Production Mapping Esri Roads and Highways
Government and Emergency Management Solutions Intelligence Solutions
Military Solutions Parks and Gardens
Real Time GIS IoT Roadway Reporter
S57 Viewer Utility and Telecommunication Solutions
Workflow Manager Services

TLS 1.2 Değişikliğinden Etkilenmeyecek Olan Ürünler

Enterprise

ArcGIS Data Store ArcGIS Enterprise Cloud Builder for AWS
ArcGIS Enterprise Cloud Builder for Azure ArcGIS Enterprise SDK
ArcGIS Web Adaptor

Business Analyst

Business Analyst Mobile Apps Business Analyst Server
Business Analyst Web App Business Analyst Web | Community Analyst

Mobil Uygulamalar 

AppStudio Player for ArcGIS – iOS|Android ArcGIS Companion
Collector for ArcGIS – iOS Collector for ArcGIS – Windows
Explorer for ArcGIS – iOS Navigator for ArcGIS – iOS
Survey123 for ArcGIS – iOS|Android Tracker for ArcGIS – iOS
Workforce Mobile – iOS

Plug-in Uygulamalar

ArcGIS for Adobe Creative Cloud ArcGIS Maps for Office
ArcGIS Maps for Power BI Esri Maps for Sharepoint
ArcGIS Maps for Microstrategy Esri Maps for IBM Cognos

ArcGIS Uygulamaları

AppStudio for ArcGIS ArcGIS for Inspire
ArcGIS Indoors ArcGIS License Manager
ArcGIS Monitor ArcGIS Sites
CityEngine Explorer for ArcGIS on OSx
GeoEnrichment Server Insights for ArcGIS – Enterprise
Insights for ArcGIS – Online Orthomaker
ArcReader Survey123 Connect

Web Apps

Operations Dashboard for ArcGIS – web Presentations for Online
Web AppBuilder – web Workforce – Web

ArcGIS Online Yapılandırılabilir Şablonlar

3D Data Visualization Basic Viewer
Compare Analysis Crowdsource Manager
Crowdsource Polling Crowdsource Reporter
Directions Edit
Elevation Profile Filter
General Geo Form
Geo List Impact Summary
Information Lookup Live Maps
Local Perspective Map Carousel
Map tools Minimalist
My Stories Public Information
Simple Map Viewer Simple Scene Viewer
Story Map Basic Map Cascade
Story Map Journal Story Map Series
Story May Shortlist Story Map Swipe and Spyglass
Story Map Tour Story Map Basic
Styler Summary Viewer
Time Aware

ArcGIS Runtime SDK

ArcGIS Runtime SDK for iOS ArcGIS Runtime for SDK MacOS

ArcGIS Web API

ArcGIS API for JavaScript
  • ArcGIS Enterprise Dağıtımınız ile ilgili TLS Protokolü güncellemesine dair değişiklikten nasıl etkileneceğini anlamak için aşağıda yer alan şemayı inceleyebilirsiniz.

ArcGIS Online ve TLS güncellemesi ile ilgili diğer sorularınız için aşağıdaki blog yazılarına da göz atmanızı öneririz.

İlgili Bağlantılar:

Esri Türkiye, 2019

Share This